Event dates not showing up

Viewing 4 reply threads
  • Author
    Posts
    • #4034
      Jonny Finity
      Participant

      Hey Stephen,

      This plugin is pretty much exactly what I was looking for! Nicely done.

      I’m experiencing a problem that, from its absence in the forum here, looks like it may be unique to me (maybe an interaction with some php code already on my site?).

      Here’s the problem: the event dates aren’t showing up, either on the main page or the event page.

      Screenshot

      Here’s what a recurring event looks like:
      Screenshot -2

      Have you seen this before? Any idea what might be causing this?

      Thanks so much!

      Jonny

      • This topic was modified 6 years, 7 months ago by Jonny Finity.
    • #4036
      Stephen Sherrard
      Keymaster

      That’s a strange one that I have not seen before.

      The first thing that comes to mind is that your WordPress settings for how to display dates is messed up, since my plugin uses that setting to determine how you want dates displayed on your site (to be consistent, and since different countries display dates in different ways).

      So, you may want to check that setting first. Go to your admin dashboard, under Settings>General, and then scroll down to date format. If the “custom” box is selected, but there are no date format characters in the input, then dates will not show.

      If that’s not the problem, then I’m not sure what would be happening, and you would need to start a process of elimination by switching themes temporarily to see if it’s a theme issue, and, if not, switching off other plugins one at a time to see if the problem goes away. If some other plugin, or the theme, is tapping into one of my hooks, or into the WordPress date display option hook, or somehow messing up the dates in the database table, there could be a conflict, but that would be a strange one.

    • #4037
      Jonny Finity
      Participant

      Bingo. You nailed it!

      Thanks!

    • #4038
      Jonny Finity
      Participant

      Not sure why date format was set to custom (it was blank). But that was an easy fix. Thanks Stephen!

    • #4052
      Stephen Sherrard
      Keymaster

      Great! Glad that was an easy fix!

Viewing 4 reply threads
  • You must be logged in to reply to this topic.