PTA Shortcode button missing on editor

HomeForumsPTA ShortcodesPTA Shortcode button missing on editor

This topic contains 6 replies, has 3 voices, and was last updated by  John Stutsman 4 weeks ago.

  • Author
    Posts
  • #9155

    Kim Wesley
    Participant

    Currently using:
    WordPress 4.4.2
    PTA Volunteer Sign Up Sheets 1.12.4
    PTA Shortcodes 1.2.2

    On February 22, 2016 everything that worked fine and I was able to insert a shortcode for an event I created. Today, when I logged in I have not been able to find the PTA drop down on my Toolbar. I am not sure what happened between now and then. I updated a few of my other plugins, but I’m not seeing a WordPress update that would have affected anything.

    Best Wishes,

    Kim

  • #9157

    Stephen Sherrard
    Keymaster

    Still working fine here on my development system with latest versions of everything, so it is not an issue with any recent WordPress update.

    Most likely a conflict with another plugin that is adding something to, or altering, the Tiny MCE editor. Might have to turn off some plugins one at a time until the PTA one re-appears, to figure out where the conflict is by a process of elimination.

    And, stupid question, but are you sure you are in “Visual” mode on the editor? Not “Text” mode, or not using some other visual editor plugin that has its own tab in the editor window?

    If you can figure out where the conflict is, I can try installing the same plugin (or theme), to see if I can recreate the issue and look for some kind of compatibility fix.

  • #9167

    Kim Wesley
    Participant

    Wow! Thank you for the super quick response. I am in Visual mode and I even have the Toolbar toggled to see both rows of options. (I did try toggling the Toolbar to the smaller setting to see if that helped any. I am going to go try turning plugins off an on to see if that helps.

    I think I may have found the difficulty. I am using a plugin called The Events Calendar by Modern Tribe (free version). I was looking for the PTA drop down link while using that editor (as it looks just like the editor for pages and posts). When I went to add a new post or a new page, the PTA drop down link is there. So, I may just have to generate the shortcode on a page and cut and paste it into the event I am attaching the sign up sheet to.

    Best Wishes,

    Kim

  • #9169

    Stephen Sherrard
    Keymaster

    Yes, it won’t show up in any editors created by other plugins… only on WordPress pages/posts.

  • #24894

    John Stutsman
    Participant

    Hello there, I am now having the same problem that was discussed above except for I am not using any other editors created by any other plugins. I’m just using the standard visual TinyMCE editor in a new post and I’m not seeing the PTA Shortcodes button anywhere. Is this plugin still working with the latest version of wordpress? If so, I could just be completely missing where this function is now found. Any help would be great!

    P.S. THANK YOU and FANTASTIC work on all your plugins… they are amazing!

  • #24896

    Stephen Sherrard
    Keymaster

    Still working just fine here with WordPress 5.1.1.

    Did you install the Classic Editor plugin? You need that to retain the original WordPress editor after they switched to the visual/blocks Gutenberg editor in WP 5+. I have NOT added anything to my plugin to add “blocks” to that Gutenberg editor, so you still have to use the shortcodes.

    Classic Editor plugin (a must is you hate the Gutenberg editor as much as everyone else does):
    https://wordpress.org/plugins/classic-editor/

    Also, the shortcodes are listed on the documentation page with all the possible arguments, so you really only need to copy and paste and change things the way you want the first time you set up your sheets display. After that, the shortcodes plugin isn’t really needed unless you need to change that on a regular basis for some reason.

    Documentation:
    https://stephensherrardplugins.com/docs/pta-volunteer-sign-up-sheets-documentation/

  • #24910

    John Stutsman
    Participant

    Yes I am using the Classic editor. I didn’t like Gutenberg AT ALL, lol.

    Ok… Its probably just another plugin I have installed causing an issue, but the documentation you have provided is stellar and works quite well for me so thank you so much! You are AMAZING!

You must be logged in to reply to this topic.