New User Meta

Viewing 2 reply threads
  • Author
    • #34931
      Cindy Moore

      On the calendar I have the setting for requiring the user to be logged in to signup form checked, so it is enabled. I also have set to use the sign-up form in a popup. On the sheets option I have enabled the signup form to use only read only. However, your calendar does not adopt this setting and logged in users must also type in their first name, last name, and email (twice). We are a church group and need volunteers to sign up for multiple events but are afraid that having them fill in their info every time is going to be prohibitive. Is that form suppose to adopt the sheet setting and use the user meta? If not, we can write a script (we are web developers that volunteer for the church) to alter that but am afraid that it would be wiped out during an update. May I have your thoughts please?
      Volunteer Sign Up Sheets: v3.6.3
      Volunteer Sign Up Sheets Calendar Display:v1.6.5
      WordPress: v5.7.2

    • #34933
      Stephen Sherrard

      Are you testing this while logged in as an admin or signup sheet manager? If so, and if you have the “Enable Sign-up form live search?” setting checked, then the fields will NOT be automatically filled in with your info. But, if you are logged in as admin, and you do NOT have that setting checked, your fields will be filled in automatically, BUT you can still edit them (NOT read only for admin and signup sheet managers so that they can signup other people easily).

      I just tested here with latest versions of everything and can confirm when logged in as admin, it works as described above. When logged in as a subscriber, the fields are populated correctly and are correctly set as readonly, and I was not able to change those values.

      Note that the very first time a user signs up for something, that meta data may not have been saved yet, so they may still have to fill out a form once. But, the next time it should all get populated and set to readonly.

      It’s working correctly here for non-admin users the way you are wanting it to, with things setup as you described.

    • #34936
      Cindy Moore

      Ah! Yes, I have disabled that setting and that is working quite well now. Thank you!

Viewing 2 reply threads
  • You must be logged in to reply to this topic.